BETA

15th January 2020

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [15/01/20 12:49 AM] with 'Partial Outage'

Issue has been resolved at [15/01/20 01:59 PM]