BETA

14th January 2020

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [14/01/20 12:19 PM] with 'Partial Outage'

Issue has been resolved at [14/01/20 12:29 PM]