BETA

14th January 2020

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [14/01/20 12:09 PM] with 'Major Outage'

Issue has been resolved at [14/01/20 12:30 PM]