BETA

14th January 2020

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [14/01/20 12:00 PM] with 'Partial Outage'

Issue has been resolved at [14/01/20 12:19 PM]