BETA

14th January 2020

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [14/01/20 11:59 AM] with 'Partial Outage'

Issue has been resolved at [14/01/20 12:10 PM]