BETA

14th January 2020

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [14/01/20 11:59 AM] with 'Major Outage'

Issue has been resolved at [14/01/20 12:09 PM]