BETA

14th January 2020

Madhya Pradesh Issue observed for 'Outgoing Calls' in Madhya Pradesh Region

Identified at [14/01/20 11:49 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [14/01/20 12:30 PM]