BETA

14th January 2020

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [14/01/20 11:39 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [14/01/20 11:59 AM]