BETA

16th March 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [16/03/19 05:50 PM] with 'Major Outage'

Issue has been resolved at [16/03/19 05:51 PM]