BETA

14th January 2020

Madhya Pradesh Issue observed for 'Outgoing Calls' in Madhya Pradesh Region

Identified at [14/01/20 10:59 AM] with 'Partial Outage'

Issue has been resolved at [14/01/20 11:10 AM]