BETA

14th January 2020

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [14/01/20 10:59 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [14/01/20 11:19 AM]