BETA

14th January 2020

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [14/01/20 10:49 AM] with 'Major Outage'

Issue has been resolved at [14/01/20 12:39 PM]