BETA

13th January 2020

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [13/01/20 07:59 PM] with 'Major Outage'

Issue has been resolved at [13/01/20 08:09 PM]