BETA

12th January 2020

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [12/01/20 04:49 PM] with 'Partial Outage'

Issue has been resolved at [12/01/20 04:50 PM]