BETA

10th January 2020

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [10/01/20 11:30 AM] with 'Major Outage'

Issue has been resolved at [10/01/20 11:39 AM]