BETA

9th January 2020

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [09/01/20 06:29 PM] with 'Partial Outage'

Issue has been resolved at [09/01/20 06:40 PM]