BETA

9th January 2020

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [09/01/20 12:30 PM] with 'Major Outage'

Issue has been resolved at [09/01/20 01:00 PM]