BETA

9th January 2020

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [09/01/20 10:40 AM] with 'Major Outage'

Issue has been resolved at [09/01/20 06:49 PM]