BETA

7th June 2017

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [07/06/17 12:12 AM] with 'Major Outage'

Issue has been resolved at [07/06/17 12:13 AM]