BETA

9th January 2020

Madhya Pradesh Issue observed for 'Outgoing Calls' in Madhya Pradesh Region

Identified at [09/01/20 10:30 AM] with 'Major Outage'

Issue has been resolved at [09/01/20 06:50 PM]