BETA

8th January 2020

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [08/01/20 03:00 AM] with 'Partial Outage'

Issue has been resolved at [08/01/20 03:29 AM]