BETA

8th January 2020

Madhya Pradesh Issue observed for 'Outgoing Calls' in Madhya Pradesh Region

Identified at [08/01/20 02:31 AM] with 'Major Outage'

Issue has been resolved at [08/01/20 02:40 AM]