BETA

8th January 2020

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [08/01/20 02:30 AM] with 'Major Outage'

Issue has been resolved at [08/01/20 02:40 AM]