BETA

8th January 2020

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [08/01/20 02:30 AM] with 'Major Outage'

Issue has been resolved at [08/01/20 02:39 AM]