BETA

7th January 2020

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [07/01/20 12:39 AM] with 'Major Outage'

Issue has been resolved at [07/01/20 12:49 AM]