BETA

4th January 2020

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [04/01/20 11:49 PM] with 'Major Outage'

Issue has been resolved at [05/01/20 07:49 AM]