BETA

3rd January 2020

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [03/01/20 11:09 PM] with 'Partial Outage'

Issue has been resolved at [03/01/20 11:19 PM]