BETA

3rd January 2020

Madhya Pradesh Issue observed for 'Incoming Calls' in Madhya Pradesh Region

Identified at [03/01/20 01:59 PM] with 'Partial Outage'

Issue has been resolved at [03/01/20 02:09 PM]