BETA

3rd January 2020

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [03/01/20 11:49 AM] with 'Partial Outage'

Issue has been resolved at [03/01/20 12:49 PM]