BETA

2nd January 2020

Madhya Pradesh Issue observed for 'Outgoing Calls' in Madhya Pradesh Region

Identified at [02/01/20 03:40 PM] with 'Partial Outage'

Issue has been resolved at [02/01/20 04:59 PM]