BETA

4th June 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [04/06/17 05:00 PM] with 'Partial Outage'

Issue has been resolved at [04/06/17 05:01 PM]