BETA

31st December 2019

Madhya Pradesh Issue observed for 'Incoming Calls' in Madhya Pradesh Region

Identified at [31/12/19 12:50 PM] with 'Partial Outage'

Issue has been resolved at [31/12/19 12:59 PM]