BETA

31st December 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [31/12/19 12:39 PM] with 'Partial Outage'

Issue has been resolved at [31/12/19 12:49 PM]