BETA

30th December 2019

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [30/12/19 11:40 PM] with 'Major Outage'

Issue has been resolved at [31/12/19 02:01 AM]