BETA

30th December 2019

Indonesia Issue observed for 'Incoming Calls' in Indonesia Country

Identified at [30/12/19 11:40 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [31/12/19 01:50 AM]