BETA

30th December 2019

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [30/12/19 11:40 PM] with 'Major Outage'

Issue has been resolved at [31/12/19 02:00 AM]