BETA

30th December 2019

Andhra Pradesh Issue observed for 'Incoming Calls' in Andhra Pradesh Region

Identified at [30/12/19 11:39 PM] with 'Major Outage'

Issue has been resolved at [31/12/19 01:59 AM]