BETA

30th December 2019

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [30/12/19 11:30 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [31/12/19 02:01 AM]