BETA

30th December 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [30/12/19 11:30 PM] with 'Major Outage'

Issue has been resolved at [31/12/19 02:00 AM]