BETA

30th December 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [30/12/19 11:29 PM] with 'Major Outage'

Issue has been resolved at [31/12/19 02:09 AM]