BETA

30th December 2019

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [30/12/19 01:49 PM] with 'Partial Outage'

Issue has been resolved at [30/12/19 01:50 PM]