BETA

30th December 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [30/12/19 01:40 PM] with 'Partial Outage'

Issue has been resolved at [30/12/19 01:49 PM]