BETA

30th December 2019

Madhya Pradesh Issue observed for 'Incoming Calls' in Madhya Pradesh Region

Identified at [30/12/19 01:19 PM] with 'Partial Outage'

Issue has been resolved at [30/12/19 01:29 PM]