BETA

30th December 2019

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [30/12/19 12:30 PM] with 'Major Outage'

Issue has been resolved at [30/12/19 12:59 PM]