BETA

29th December 2019

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [29/12/19 03:29 PM] with 'Partial Outage'

Issue has been resolved at [29/12/19 03:30 PM]