BETA

29th December 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [29/12/19 12:09 PM] with 'Partial Outage'

Issue has been resolved at [29/12/19 12:19 PM]