BETA

29th December 2019

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [29/12/19 04:09 AM] with 'Partial Outage'

Issue has been resolved at [29/12/19 04:29 AM]