BETA

29th December 2019

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [29/12/19 02:39 AM] with 'Major Outage'

Issue has been resolved at [29/12/19 02:59 AM]