BETA

2nd June 2017

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [02/06/17 08:15 AM] with 'Partial Outage'

Issue has been resolved at [02/06/17 08:19 AM]