BETA

28th December 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [28/12/19 02:09 PM] with 'Partial Outage'

Issue has been resolved at [28/12/19 02:10 PM]